Portal Loading Issues
Incident Report for i360
Resolved
This incident has been resolved.
Posted May 29, 2019 - 15:36 EDT
Update
Updated to reflect newly affected components.
Posted May 29, 2019 - 15:03 EDT
Update
We are continuing to investigate this issue.
Posted May 29, 2019 - 14:56 EDT
Investigating
We are currently investigating this issue.
Posted May 29, 2019 - 14:47 EDT
This incident affected: i360 Walk (iOS, Android), i360 Call (iOS, Android, callingfromhome.com), i360 Text (SMS, MMS), and i360 (Basic Search, Advanced Search, Combined Search, Survey Builder, Volunteer Management).