Walk Issues
Incident Report for i360
Resolved
This incident has been resolved.
Posted Mar 09, 2024 - 19:10 EST
Investigating
We are currently investigating this issue.
Posted Mar 09, 2024 - 17:12 EST
This incident affected: i360 Walk (iOS, Android) and i360 Call (iOS, Android, callingfromhome.com).