Portal & App Timeouts
Incident Report for i360
Resolved
i360 has been impacted by the major Cloudflare outage, which also impacted a wide section of the internet.
Posted Jul 17, 2020 - 17:38 EDT
Investigating
We are currently investigating this issue.
Posted Jul 17, 2020 - 17:17 EDT
This incident affected: i360 Call (iOS, Android, callingfromhome.com), i360 (Basic Search, Advanced Search, Combined Search, Survey Builder, Survey Publishing, Canvassing Report, Volunteer Management, Dashboards, Exports, Imports), i360 Text (SMS, MMS), i360 Walk (iOS, Android), and i360 Send, i360 Action, i360 Connect, i360 Vote, i360 Events, API.