Error Message When Attempting to Login to i360 Portal
Incident Report for i360
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 15:31 EDT
Investigating
We are currently investigating this issue.
Posted Jun 22, 2020 - 15:18 EDT
This incident affected: i360 (Basic Search, Advanced Search, Combined Search, Survey Builder, Survey Publishing, Canvassing Report, Volunteer Management, Dashboards, Exports, Imports).