i360 Call Outage
Incident Report for i360
Postmortem

Message from Twilio: A subset of Twilio products were degraded for 6 minutes between 11:37AM and 11:43 Pacific Time on 10/29/2020. During this period of time customers may have experienced unavailability of Twilio’s API and websites.

Posted Oct 29, 2020 - 16:05 EDT

Resolved
We believe this was related to an external provider issue.
Posted Oct 29, 2020 - 15:01 EDT
Investigating
We are currently investigating this issue.
Posted Oct 29, 2020 - 14:50 EDT
This incident affected: i360 Call (iOS, Android, callingfromhome.com).