Degraded Performance from Twilio Voice
Incident Report for i360
Resolved
This incident has been resolved.
Posted Oct 30, 2020 - 10:05 EDT
Investigating
We are monitoring Twilio Voice issues. Twilio status page: https://status.twilio.com/

If you are experiencing issues with i360 Call, please email [email protected]
Posted Oct 29, 2020 - 16:43 EDT
This incident affected: i360 Call (iOS, Android, callingfromhome.com).