i360 Call Issues
Incident Report for i360
Resolved
This incident has been resolved.
Posted Aug 22, 2022 - 10:04 EDT
Investigating
We are currently investigating this issue.
Posted Aug 22, 2022 - 09:42 EDT
This incident affected: i360 Call (iOS, Android, callingfromhome.com).