Political Geo Tab in Basic Search Times Out
Incident Report for i360
Resolved
This incident has been resolved. We apologize for any inconvenience you experienced.
Posted 4 months ago. May 02, 2019 - 15:00 EDT
Update
We are continuing to work on a fix for this issue.
Posted 4 months ago. May 02, 2019 - 12:57 EDT
Identified
Our Products Team has identified the issue and is working to implement a fix.
Posted 4 months ago. May 02, 2019 - 10:55 EDT
This incident affected: i360 (Basic Search).