Incident
Incident Report for i360
Resolved
This incident has been resolved.
Posted Jul 07, 2023 - 14:57 EDT
Investigating
We are currently investigating this issue.
Posted Jul 07, 2023 - 14:39 EDT
This incident affected: i360 Walk (iOS, Android), i360 Call (iOS, Android, callingfromhome.com), i360 Portal v4 (Basic Search, Advanced Search, Contacts Management, Exports, Imports, Survey Builder, Survey Publishing, Dashboards, Web Pages), and i360 Text, i360 Action, i360 Connect, i360 Vote, i360 Events, API.