Portal Loading Issues
Incident Report for i360
Resolved
This incident has been resolved.
Posted May 31, 2019 - 10:35 EDT
Investigating
We are currently investigating this issue.
Posted May 31, 2019 - 09:04 EDT
This incident affected: i360 Walk (iOS, Android), i360 Call (iOS, Android, callingfromhome.com), and i360 (Basic Search, Survey Builder, Canvassing Report, Volunteer Management).