Responses Not Sticking in i360 Walk
Incident Report for i360
Resolved
This incident has been resolved.
Posted Apr 30, 2022 - 13:20 EDT
Identified
Our team has identified the issue and is implementing a resolution.
Posted Apr 30, 2022 - 12:45 EDT
Investigating
Our team is investigating this issue.
Posted Apr 30, 2022 - 11:53 EDT
This incident affected: i360 Walk (iOS, Android).