Survey Issues
Incident Report for i360
Resolved
This incident has been resolved.
Posted Jun 15, 2022 - 09:36 EDT
Investigating
Clients may experience issues with surveys while a Portal release is in progress.
Posted Jun 15, 2022 - 09:17 EDT
This incident affected: i360 Walk (iOS, Android) and i360 Call (iOS, Android, callingfromhome.com).